Cloudflare Issue
Incident Report for Hydrogen Studio
Resolved
This incident has been resolved.
Posted Jul 17, 2020 - 14:42 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 17, 2020 - 14:36 PDT
This incident affected: Websites (https://hydrogenbot.xyz, https://hydrogenbot.xyz/covid-19).